mozdev.org

PluginDoc    

plugindocs:
resources:

安裝前注意事項

翻譯: 中文 法文 波蘭文 西班牙文

所有作業系統
Windows
外插模組掃描
MacOS 8.5 - 9.x
Linux
MacOS X

所有作業系統

當安裝任何瀏覽器外插模組時,你必須先關閉 Mozilla 後再重新開啟。此為安裝任何外插模組的 *必要* 措施,否則瀏覽器無法識別新的外插模組。

要檢查安裝過什麼外插模組,在位址列輸入 about:plugins 而後按下 Enter。

Windows

在 Windows 上,Mozilla 會在以下的幾個位址找尋外插模組:

如果你在 Netscape 4.x 上曾安裝任何 plugin,你可能不需要再為 Mozilla 安裝一份。

如果您使用 Mozilla 的快速啟動,則安裝 plugin 時請先離開將快速啟動關閉或至少完全離開 Mozilla。你可以在系統列的 Mozilla 圖示上按右鍵以達目的。

Quick Launch
Mozilla 快速啟動圖示

外插模組掃描

Mozilla 會自動去尋找 Acrobat Reader, QuickTime, Java, Windows Media Player 的安裝資料夾與 Netscape 4.x 的 plugins 資料夾.

欲設定這些動作, 請編輯 winpref.js 的以下幾行程式. (此檔會在 Mozilla 資料夾下的 defaults\pref 子資料夾中).

// 掃描 Sun JRE 安裝資料夾以決定 Java 的位置, 後面的設定為所要掃描的最小版本號
// 備註: 如果 security.enable_java 非為 true 的話, 就不會去掃描.
pref("plugin.scan.SunJRE", "1.3");

// 掃描 Adobe Acrobat 安裝資料夾以決定其外插模組的位置, 後面的設定為所要掃描的最小版本號
pref("plugin.scan.Acrobat", "5.0");

// 掃描 QuickTime 安裝資料夾以決定其外插模組的位置, 後面的設定為所要掃描的最小版本號
pref("plugin.scan.Quicktime", "5.0");

// 掃描 Window Media Player 安裝資料夾以決定其外插模組的位置, 後面的設定為所要掃描的最小版本號
pref("plugin.scan.WindowsMediaPlayer", "7.0");

// 掃描 Windows 的 PLID 相關登錄碼中所指定之目錄, 以尋找其他外掛模組
// 現在為 HKLM\Software\MozillaPlugins\xxxPLIDxxx\Path
pref("plugin.scan.plid.all", true);

// 控制對 Navigator 4.x plugins 資料夾的掃描動作
// 如果沒有設定此偏好選項, 則預設會挑選較著名的外插模組如 Flash, Shockwave, Acrobat, 與 Quicktime 等.
// 如果設定為 true, 則會挑選出*所有*的外插模組
// 而如果設定為 false 則不予掃描
//pref("plugin.scan.4xPluginFolder", false);

想要關閉除 Netscape 4.x plugin 資料夾之外的掃描動作, 則請在不想做的動作程式行最前方加上「//」來將其設為註解. 而要取消 4.x plugin 資料夾的掃描動作, 則請將該行設定前之註解記號消去. 而如果想要讓所有在 4.x plugin 資料夾中的外插模組皆能被選出供使用, 則請將該行註解記號消去後也一並將最後面的「false」改為「true」.

要設定只掃描某最小版本號以上的資料夾時, 輸入您需要的最小版本號 (這在安裝了多種版本的時候很方便). 這種方式在使用 Java 時可以設定為只掃描 1.4 以上的版本, 相當方便.

MacOS 8.5 - 9.x

在 Macintosh 上,Mozilla 會在自己的 plugins 資料夾和 System 資料夾下的 Internet Plug-Ins 資料夾中找尋 外插模組。如果你已經在 Internet Plug-Ins 中安裝了外插模組,便不需要為 Mozilla 另行安裝一份。

Linux

在 Linux 上,Mozilla 會在以下位址找尋 plugin:

MacOS X

在 MacOS X 上,Mozilla 會在以下位址找尋 plugin:

中文版責任編譯: Bob Chao, 趙柏強 (October 19, 2003)
有任何翻譯疏失請予指教請予指教
Labelled with ICRAValid HTML 4.01 Strict!Valid CSS!