mozdev.org

Traductions : cz | de | en | es | fr | it | ja | nl | pl | zh

Les plugins de Mozilla sous Linux (x86)

Si vous installez des plugins sans les droits d'administrateur, utilisez le répertoire ~/.mozilla/plugins plutôt que celui où Mozilla est installé. Vous devez avoir créé ce répertoire d'abord. Mozilla Firefox utilise également un répertoire ~/.mozilla/plugins pour cela.

Certains plugins nécessitent que votre version de Mozilla ait été compilée avec une version spécifique du compilateur gcc. Vous pouvez utilisez about:buildconfig pour vérifier quelle version de gcc a été utilisée pour compiler votre navigateur.

FAQ: La mention "Non testé" pour certains plugins veut simplement dire qu'ils n'ont pas été testés par PluginDoc. Ils peuvent fonctionner mais n'ont pas été vérifiés. Ne signalez pas de bugs à ce sujet !

Firefox 1.0: Supporté
Mozilla 1.7: Supporté

Adobe Reader

Site Web
Version: 7.0.5
  1. Installez Adobe Reader.
  2. Créez un lien symbolique du fichier nppdf.so dans le répertoire plugins de Mozilla.
  3. Assurez vous qu'une copie d'acroread soit dans votre PATH.

De plus, Adobe Reader 7.0 contient un script d'installation du plugin pour le navigateur. Ce script est installé par défaut à l'emplacement suivant :

/usr/local/Adobe/Acrobat7.0/Browser/install_browser_plugin
Téléchargement Adobe Reader 7.0.5 - Tarball ou RPM

Firefox 1.0: Supporté
Mozilla 1.7: Supporté

Adobe SVG Viewer

Site Web
Version: 3.01 Beta (Build 88)

Note:Firefox 1.5 intègre nativement un support SVG et n'a donc plus besoin de ce plugin. Pour plus d'informations concernant le support SVG dans Firefox 1.5, consultez la page Firefox 1.5 SVG Status.

  1. Fermez toutes les applications utilisant une version d'Adobe SVG Viewer.
  2. En tant qu'administrateur root, extrayez le contenu du paquetage d'installation et exécutez le script adobesvg-3.01/install.sh. Adobe recommande d'extraire les fichiers sous /usr/local, bien qu'un autre emplacement fonctionnerait aussi.
  3. Copiez libNPSVG3.so dans le répertoire plugins de votre navigateur.

Important! Toutes les anciennes versions d'Adobe SVG Viewer ne fonctionnent absolument pas. De plus, veuillez lire le chapitre Know Issues du fichier README avant l'installation.

Important! Il a été signalé que si la variable LC_NUMERIC n'est pas initialisée avec en_EN, le plugin ne fonctionnerait pas correctement.

Téléchargement SVG Viewer 3.01 Beta

Firefox 1.0: Non supporté
Mozilla 1.7: Non supporté

Cult3D

Site Web
Version: 5.2 Beta 1
Ce plugin n'est pas supporté par Mozilla 1.x.
Téléchargement Cult3D Downloads

Firefox 1.0: Supporté
Mozilla 1.7: Supporté

DjVuLibre

Site Web
Version: 3.5.13
  1. Installez DjVuLibre.
  2. Copiez ou créez un lien symbolique vers nsdejavu.so dans le répertoire plugins de Mozilla.
Page d'accueil DjVuLibre

Firefox 1.0: Supporté
Mozilla 1.7: Supporté

FreeWRL

Site Web
Version: 1.15
  1. Installez FreeWRL. Si vous le compilez depuis les sources, assurez vous d'éditer vrml.conf en conséquence autrement il ne fonctionnera pas.
  2. Si votre navigateur n'utilise pas un système de répertoire global de plugins, créez un lien symbolique de npfreewrl.so dans le répertoire plugins de Mozilla.
Page d'accueil FreeWRL

Firefox 1.0: Supporté
Mozilla 1.7: Supporté

gxine

Site Web
Version: 0.33
  1. Compilez et installez gxine.
  2. Créez les liens symboliques vers les fichiers suivants dans le répertoire plugins de votre navigateur : gxineplugin.a gxineplugin.la gxineplugin.so.
Page d'accueil xine

Firefox 1.0: Supporté
Mozilla 1.7: Supporté

Helix Player

Site Web
Version: MS1 et suivante
  1. Installez Helix Player.
  2. Copiez le fichier nphelix.so vers le répertoire plugins de Mozilla et le fichier nphelix.xpt vers le répertoire components.
Page d'accueil Helix Player

Firefox 1.0: Supporté
Mozilla 1.7: Supporté

Java Runtime Environment

Site Web
Version: 1.4.2_05 ou suivante
  1. Installez Java Runtime Environnement. (Consultez l'aide de Sun)
  2. Créez un lien symbolique vers libjavaplugin_oji.so dans le répertoire plugins de votre navigateur. À moins que vous n'utilisiez une ancienne version de Mozilla ou une version personnelle compilée avec gcc 2.9x, ce fichier se situe dans le répertoire plugin/i386/ns7 pour JRE 5.0, ou plugin/i386/ns610-gcc32 pour JRE 1.4.2.

Important! Ne pas copier le plugin directement dans le répertoire plugins de Mozilla. Si vous faites cela, votre navigateur plantera à chaque fois que vous tenterez d'ouvrir une page contenant une applet Java.

Note: Java Runtime Environment 5.0 (1.5.0) est maintenant disponible. Cette version corrige de nombreux problèmes rencontrés par les utilisateurs. Une mise à jour est hautement recommandée.

Note: Les instructions listées ici sont valables pour le Java Runtime Environnement de Sun. D'autres Java Runtime Environnement, tels que celui disponible chez IBM ou le projet Blackdown, peuvent également être utilisés avec Mozilla.


Firefox 1.0: Supporté
Mozilla 1.7: Supporté

Macromedia Flash Player

Site Web
Version: 7.0r63
  1. Téléchargez Flash Player 7.0.
  2. Décompressez le, ensuite copiez les fichiers libflashplayer.so et flashplayer.xpt vers le répertoire plugins de votre navigateur.

Note:Macromedia Flash Player 7.0r63 corrige quelques failles de sécurité.


Firefox 1.0: GTK2 seulement
Mozilla 1.7: GTK2 seulement

mozplayerxp

Site Web
Version:
  1. Décompressez le contenu de plugin.tgz vers le répertoire plugins de votre navigateur.
Note: Si votre mplayer n'est pas situé dans le répertoire /usr/local/bin/mplayer, vous devrez créer un script vers cet emplacement de la façon suivante (en remplaçant le chemin indiqué par celui de votre mplayer) :
#!/bin/sh
/home/michael/scratch/mplayer-cvs/mplayer -ao esd $*
     
Page d'accueil mozplayerxp

Firefox 1.0: Supporté
Mozilla 1.7: Supporté

MozPlugger

Site Web
Version: 1.5.1
  1. Extraire les sources
  2. A partir du répertoire des sources, exécutez la commande "make linux"
Pour faire une installation globale, copiez mozplugger.so vers le répertoire plugins de votre navigateur, mozpluggerrc dans /etc, et mozplugger-helper + mozplugger-controller dans /usr/bin
Pour faire une installation locale, copiez mozplugger.so vers ~/.mozilla/plugins, et mozpluggerrc + mozplugger-helper + mozplugger-controller vers ~/.mozilla
Page d'accueil MozPlugger

Firefox 1.0: Non testé
Mozilla 1.7: Non testé

mplayerplug-in

Site Web
Version: 2.80
  1. Extraire les sources.
  2. Lancer ./configure.
  3. Lancer make.
  4. Copier mplayerplug-in.so vers le répertoire plugins de votre navigateur, et mplayerplug-in.xpt vers le répertoire components.

Note: Si vous n'utilisez pas une version de Mozilla compilée avec le support GTK2, vous devez exécuter ./configure avec l'option --enable-gtk1. Pour plus d'informations, reportez vous à la page de téléchargement.

Téléchargement mplayerplug-in

Firefox 1.0: Supporté
Mozilla 1.7: Supporté

Plugger

Site Web
Version: 5.0
  1. Extrayez les sources
  2. À partir du répertoire des sources, exécutez la commande "make linux"
  3. Si vous avez des droits d'administrateur, exécutez la commande "make install" an tant qu'administrateur. Autrement, exécutez la commande "make localinstall".
Important! Plugger 4.0 peut planter sur des pages contenant des fichiers midi inclus. Voir le bug 74080.
Page d'accueil Plugger

Firefox 1.0: Supporté
Mozilla 1.7: Supporté

RealPlayer 10

Site Web
Version: 10.0.0.297

  1. Installez RealPlayer 10.
  2. Copiez le fichier nphelix.so vers le répertoire plugins et le fichier nphelix.xpt vers le répertoire components de Mozilla.
  3. Assurez vous qu'un lien symbolique vers le script de realplay se trouve dans la variable environnement PATH.

Note: Si vous installez le paquetage RPM de RealPlayer 10, ces fichiers sont situés dans /usr/local/RealPlayer/mozilla.

Important! L'installation de la version 10 de RealPlayer ne désinstalle pas la version 8 si cette dernière est présente sur votre système. Si vous conservez les deux versions de RealPlayer 8 et RealPlayer 10, enlevez le plugin (rpnp.so) de RealPlayer 8 présent dans le répertoire plugins de Mozilla. Des problèmes peuvent apparaître si les deux plugins sont laissés dans ce répertoire.

Téléchargement RealPlayer 10 pour Unix

Firefox 1.0: gcc 2.9x seulement
Mozilla 1.7: gcc 2.9x seulement

RealPlayer 8

Site Web
Version: 8.0
  1. Installez RealPlayer 8.
  2. Copiez le fichier rpnp.so vers le répertoire plugins de votre navigateur. Si vous avez installé le paquetage RPM de RealPlayer 8.0, le fichier se trouvera dans le répertoire /usr/lib/RealPlayer8/
Important! Le plugin RealPlayer 8 ne fonctionne pas avec des versions de Mozilla compilée avec le compilateur gcc 3.x. Vous devriez utiliser RealPlayer 10 à la place. Si vous ne pouvez pas utiliser RealPlayer 10, le bug 213234 n'a pas de solution transitoire.
Téléchargement RealPlayer 8 pour Unix

CrossOver Office - Faites fonctionner des plugins pour Windows sous linux

CrossOver Office vous permet d'exécuter des plugins de navigateur pour Windows sur une système d'exploitation Linux, en utilisant Wine.

Macromedia Shockwave, Windows Media Player et QuickTime sont supportés. Reportez vous à la liste des plugins compatibles pour plus de détails.

CrossOver Office est un logiciel commercial, coutant $39.95 (US) pour télécharger la version Standard, $74.95 (US) pour télécharger la version professionelle, ou $84.95 (US) plus les frais de port pour la version Professionnelle sur CD. Une version de démonstration est également disponible. Ce logiciel est entièrement compatible avec Mozilla 1.x. La version actuelle est CrossOver Office 5.0.1.

Vous pouvez également consulter la documentation sur Crossover Office Standard, ou l'acheter à partir de Codeweavers Store.

Note: Dans les versions précédentes de ce logiciel jusqu'à la version 2.1.0, cette fonctionnalité était proposée par le Crossover Plugin, qui n'est plus un produit indépendant. L'achat de CrossOver Office est aussi une excellente occasion d'aider le projet Wine, car des contributions substantielles sont faites par CodeWeavers.